Service Outage

Incident Report for FortiCare Elite Service Status

Resolved

This incident has been resolved.
Posted May 16, 2023 - 23:15 UTC

Investigating

Service outage impacting all customers.
Posted May 16, 2023 - 23:04 UTC
This incident affected: FortiCare Elite Status (FortiCare Elite).